Technorati提醒:不升级您的WordPress可能会造成负面影响

看到Technorati官方的一则消息,《Vulnerable WordPress Blogs Not Being Indexed》,也就是说,有漏洞的WordPress博客是不会被检索的。补充:至于如何影响检索,我也不得而知。原意似乎是说完全不予检索,可是我的Blog仍然是一个老版本,却没有受到太大的影响。

除了在wordpress.com注册的博客不会受到影响之外,所有自己安装的WordPress都可能受到影响。文章提到的漏洞是2.3.3出现的,这个漏洞会导致许多spam悄悄地在被入侵的博客中插入垃圾链接,不动声色地连接到垃圾页面。这里的“不动声色”是指通过修改链接样式,让管理员难以察觉,而事实上链接存在与博客之中。

原文还表明,对于可能存在风险的博客,(Techonorati)官方将不予检索。而对于那些不存在风险的博客,可能也会被Technorati、Google、Yahoo判为“Spam”。

我的博客使用的还是2.2.2,一个非常古老的版本(去年5月16日),我之所以仍然不升级是因为UTW的tag数据在导入2.5.1的数据结构后表现异常。有一个名为“张信哲”的tag在2.5.1的查询中无法检索到相应文章。我用新的2.5.1做过测试,发现并非“张信哲”这三个汉字(编码)所造成的问题,因此很可能是我的数据库内部的问题。毕竟,从L-Blog转到LBS,再从LB转到WordPress,尤其是tag体系的转换(从LBS的一个自己改的不规范的tag插件,到UTW,再到WordPress的自身tag机制),存在非常大的问题。

最近事情比较多,等腾出手一定要把这个问题给解决掉了。

附,WordPress的版本发布历史记录:

  1. .70 May 27, 2003
  2. 1.0 January 3, 2004
  3. 1.2 May 22, 2004
  4. 1.5 February 17, 2005
  5. 2.0 December 31, 2005
  6. 2.1 January 22, 2007
  7. 2.2 May 16, 2007(awflasher.com目前使用的版本)
  8. 2.3 September 24, 2007
  9. 2.5 March 29, 2008

另外,预计WordPress 2.6将在7月7日发布;2.7将在11月10日发布。

Advertisements

12 thoughts on “Technorati提醒:不升级您的WordPress可能会造成负面影响

    1. 这位看来是个对物理有特殊兴趣的朋友噢…
      现在哪里都合协啦… 所以上网尽量带Tor…

  1. 还有这等事?好在早就升级到了2.5.1,感觉2.5还是有不少改进的,现在用的很舒服.2.6 beta的Demo也看了下,支持Google Gears是个很不错的功能.顺便纠正一个笔误:第三句话的”愿意”应该是”原意”

  2. wordpress更新实在太频繁了,最近出了3.4,实在是不想更了,但不更吧又怕将来更新时隔的版本太多,更吧之前的程序自己修改过。。。

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s